이번 OSX 메버릭스가 10.9.4 로 업그레이드 하면서 SSD 의 Trim 활성화 명령어가 달라졌다고 합니다. 원래 최신 SSD 에서는 Trim 지원이 되어 있기 마련인데, 제가 이번에 새로 구입한 samsung ssd evo 지원 여부를 확인 하지 않고, 일단 이전 SSD 때 사용했던 trim enabler 를 실행시켰습니다. 그리고 위의 사실을 기억하지 못하고 trim enabler 를 실행하니 아래와 같은 오류가 났습니다. 



Failed to bless helper. Error: Error Domain=kSMErrorDomainFramework Code=3 "The operation couldn’t be completed. (kSMErrorDomainFramework error 3 - The client and tool did not match requirements.)" UserInfo=0x60000027a140 {NSDescription=The client and tool did not match requirements.}


다행히 back to the Mac 에서 읽은 기억이 나 찾아 들어가 터미널 명령어를 실행한 뒤 리부팅 시켰습니다.



그냥 새로 Trim Enabler 를 다운 받아서 실행해도 될 듯 싶네요. 이전 버전에서 업그레이드 하면 같은 오류가 반복될 수 있습니다. 제 기기에서 오류가 되풀이 되어 혹시나 하고 새로 다운받았더니 정상적으로 실행 됩니다. 



Back To the Mac 의 좋은 글 항상 감사드립니다. :)


저작자 표시
신고

posted by youp_han matrim



티스토리 툴바