무슨이유인지.. 


아침에..

오래된 아이폰 3gs 를 가지고 나왔습니다.

이것저것 눌러보다.. 엇.. 탈옥이 되어 있는걸 발견하고.. ㅋㅋ 


탈옥 왜 했지? 할정도로.. 이렇다할 앱 하나 설치 안되어 있더군요.


그래서 다시 복원을 결정..


예전엔 DFU 모드 (공장초기화) 로 들어가 복원 누르면 되었는데 오류를 뱉어 내네요.

/etc/hosts 파일 내용 수정이 필요했는데..


아래 링크 들어가서 있는 그대로 적은 후 잘 마무리 했습니다. 링크 공유 합니다.

오류 메세지 :

1. Error 17

2. Error 1639

3. Errors 3000-3020

4. Error 3194

5. Errors 3100-3999

6. This device isn't eligible for the requested build


제 컴퓨터에서 났던 오류는 6번 입니다.

해결 링크 : https://support.apple.com/en-us/HT201442


/etc/hosts 파일 내용에 아래 그림처럼 gs.apple.com 관련된 아이피와 내용이 없었는데요.. 추가 해주고 #를 앞에 적어준뒤 저장하고 재시도 해보니 잘 되었습니다.





저와 같은 오류로 고생하시는 분들이 있을까 해서 적어봤습니다.


감사합니다..

저작자 표시
신고

posted by youp_han matrim
  • 좋은정보 2016.10.25 17:32

    관리자의 승인을 기다리고 있는 댓글입니다







애플 모바일 기기들의 iOS 8.1 버전이 출시되었습니다.

iOS 8.1 의 업데이트 내용은 다음과 같습니다.


이 릴리즈는 다음과 같은 새로운 기능, 개선사항 및 오류 수정사항을 포함합니다.

  • 사진의 새로운 기능, 개선사항 및 오류 수정사항
    • 베타 서비스로 iCloud 사진 보관함 추가
    • iCloud 사진 보관함이 활성화되어 있지 않을 때 사진 App 및 나의 사진 스트림 앨범에서 카메라 롤 앨범 추가
    • 타임랩스 비디오를 캡처하기 전에 공간이 충분하지 않을 때 알림 제공
  • 메시지의 새로운 기능, 개선사항 및 오류 수정사항
    • iPhone 사용자가 iPad 및 Mac에서 SMS 및 MMS 문자 메시지를 주고 받을 수 있는 기능 추가
    • 검색 결과가 때때로 표시되지 않던 문제 해결
    • 읽은 메시지가 읽음으로 표시되지 않던 오류 수정
    • 그룹 메시지 문제 수정
  • 일부 베이스 스테이션에 연결될 때 발생하던 Wi-Fi 성능 문제 해결
  • Bluetooth 핸즈프리 장비에 연결되지 않던 문제 수정
  • 화면 회전 기능이 제대로 동작하지 않던 오류 수정
  • 셀룰러 데이터에 대해 2G, 3G, LTE 네트워크 중 선택할 수 있는 옵션 추가
  • 비디오가 때때로 재생되지 않던 Safari 문제 수정
  • Passbook 패스에 대해 AirDrop 지원 추가
  • Siri와 별개로 키보드 설정의 받아쓰기를 활성화할 수 있는 옵션 추가
  • 백그라운드에서 HealthKit App이 데이터에 접근할 수 있도록 활성화
  • 손쉬운 사용 개선사항 및 오류 수정
    • 사용법 유도가 제대로 동작되지 않던 문제 수정
    • VoiceOver가 타사 키보드와 동작하지 않을 수 있는 오류 수정
    • iPhone 6 및 iPhone 6 Plus에서 MFi 보청기를 사용할 때 안정성 및 오디오 음질 향상
    • 다른 번호로 전화를 걸 때까지 발신음이 멈추는 VoiceOver 문제 수정
    • 필기, Bluetooth 키보드 및 점자 디스플레이를 VoiceOver와 사용할 때 안정성 향상
  • iOS 업데이트용 OS X 캐싱 서버를 제대로 사용할 수 없던 문제 수정

일부 기능은 일부 국가 또는 지역에서만 사용할 수 있습니다.

이 업데이트의 보안 콘텐츠에 관한 자세한 정보를 보려면 다음 웹 사이트를 방문하십시오.

http://support.apple.com/kb/HT1222?viewlocale=ko_KR



저작자 표시
신고

posted by youp_han matrim



Yosemite DP2 를 사용하면서 parallels9 의 업데이트가 늦어져, 도저히 사용이 불가 하게 되어 다운그레이드를 해야 헀습니다.

인터넷을 찾아보니.. ㅡ,.ㅡ Mavericks 로 덮어 쓰라고 하더군요



그냥 다 지우고.. 새로 OSX 를 설치 할까 했는데.. 백업을 안했더군요. 백업을 해야 합니다. 중요한 자료가 많았습니다. 뭔생각이였는지.. 근데 Finder 가 열리지 않습니다. 정말..이지..OTL..



1. Finder 가 작동 하지 않은 현상은, 따로 인터넷에서 찾아보니 이전 버전에서 Mavericks 로 업그레이드 시, 일어날 수 있는 현상에 대해서만 나옵니다. 요세미티에서 다운한 뒤 이런 현상을 겪은 사람들은 없어 보이더군요. 


그래서 혹시나 해서 그냥 Mavericks 의 버전 업데이트를 실행했습니다. 혹시나.. 혹시나 해서요.. 그랬더니 바로 Finder 기능은 정상 작동 하더군요. 문제는 백업을 하려고 하는 자료들이.. 옮겨지지 않는 현상 외 여러 다수의 덮어 씌운 매버릭스에서 정상적인 사용이 힘든 현상이 발생했습니다.


2. 그게.. 계정에 admin 권한이 없어져 버렸더군요. 계정에서 admin 권한이 없어지면, 다운받은 어플들을 응용 프로그램에 옮길 수도 없고, 다른 시스템 설정을 바꾸려고 하면 잠긴 열쇠 그림을 풀어야 하는데 불가능 합니다. 온갖 sudo 명령어들도 실행이 안되었지요.


그래서 계정에 admin 기능을 넣는 방법을 알아봤습니다.



링크대로 루트 계정으로 로그인 하여 사용하는 계정에 admin 권한을 부여 한 뒤..

백업을 실행 하여 모든 중요한 자료들을 백업 하였습니다.


그리고 다시 SSD 를 밀어버리고, 새로 설치 하였습니다.

저작자 표시
신고

posted by youp_han matrim
  • BlogIcon youp_han matrim 2014.07.21 12:06 신고


    지금은 다시 요세미티 DP3 를 사용중입니다. 파랄렐즈9 가 업그레이드 이후 요세미티에서 작동합니다. :)
    하지만 다운그레이드.. 하면서 고생을 ㅠㅠ..
    백업의 생활화.. 해야겠습니다.



이번 OSX 메버릭스가 10.9.4 로 업그레이드 하면서 SSD 의 Trim 활성화 명령어가 달라졌다고 합니다. 원래 최신 SSD 에서는 Trim 지원이 되어 있기 마련인데, 제가 이번에 새로 구입한 samsung ssd evo 지원 여부를 확인 하지 않고, 일단 이전 SSD 때 사용했던 trim enabler 를 실행시켰습니다. 그리고 위의 사실을 기억하지 못하고 trim enabler 를 실행하니 아래와 같은 오류가 났습니다. 



Failed to bless helper. Error: Error Domain=kSMErrorDomainFramework Code=3 "The operation couldn’t be completed. (kSMErrorDomainFramework error 3 - The client and tool did not match requirements.)" UserInfo=0x60000027a140 {NSDescription=The client and tool did not match requirements.}


다행히 back to the Mac 에서 읽은 기억이 나 찾아 들어가 터미널 명령어를 실행한 뒤 리부팅 시켰습니다.



그냥 새로 Trim Enabler 를 다운 받아서 실행해도 될 듯 싶네요. 이전 버전에서 업그레이드 하면 같은 오류가 반복될 수 있습니다. 제 기기에서 오류가 되풀이 되어 혹시나 하고 새로 다운받았더니 정상적으로 실행 됩니다. 



Back To the Mac 의 좋은 글 항상 감사드립니다. :)


저작자 표시
신고

posted by youp_han matrim

svn 서버에 git 클라이언트로 접속하여 쓰관리를 하고 있습니다. 개발자용 Mac OSX 10.8 Mountain Lion 골드 마스터 버전을 테스트 겸 설치하고 프리뷰 버전의 xCode 를 다운 받아 설치한뒤 테스트 해 보았습니다.

git client (source tree: 무료) 를 사용하여 사무실 svn 에 접속한뒤 pull 혹은 push 하려고 하니 에러가 나더군요. 자세한 내용은 캡쳐를라지 않아 알 수는 없지만 SVN/Core.pm in @INC 어쭈구 하면서 svn::_Core 에러 가 났습니다. 당황하여 인터넷을 찾아보니 문제해결이 되었다는군요 

참고 싸이트 : (http://victorquinn.com/blog/2012/02/19/fix-git-svn-in-mountain-lion/)

1. xCode 에 Command Line Tools 를 설치합니다. 설치하시려면, xCode 를 실행하시고 Preference 에 들어가 Downloads 탭을 누릅니다.


그림에서는 Command Line Tools 가 installed 라고 나오지만, 그건 이미 제 맥북에서는 설치가 되었기 때문입니다. 아마 설치 하지 않은 분들은 install 이라는 버튼이 보일것이며, 누르면 다운로드/설치 상태바가 나옵니다.


2. 그런뒤 터미널을 열어 아래 명령어를 넣어줍니다. 

엔터를 누르면 암호를 넣으라고 합니다. GIT svn 명령어는 Perl 라이브러리들이 필수 입니다. Mountain Lion 에서는 Perl 라이브러리들이 링크되어 있지 않기 때문에 오류가 나는 건데요, 위의 명령어를 넣어주어 라이브러리들을 링크 해줍니다.

$ sudo ln -s /Applications/Xcode.app/Contents/Developer/Library/Perl/5.12/darwin-thread-multi-2level/SVN /System/Library/Perl/Extras/5.12/SVN


3. 설치가 잘 되었는지는 $ git svn rebase 명령어를 쳐 보시면 알 수 있지만, 제 컴퓨터에서는 알 수 없는 명령어라고 나오더군요. 여하튼 이 명령어를 치게 되면, Subversion core 는 찾을 수 있지만, 다른 필요한 라이브러리들을 찾을 수 없다고 나온다고 합니다. 그래서 아래 명령어를 또한번 적어 넣어줍니다.

$ sudo ln -s /Applications/Xcode.app/Contents/Developer/Library/Perl/5.12/darwin-thread-multi-2level/auto/SVN/ /System/Library/Perl/Extras/5.12/auto/SVN

2번과 3번의 명령어엔 auto 가 두개 더 들어가 있습니다. 위의 명령어로 모든 Subversion Perl 디렉토리에서 필요로 하는 모든 라이브러리들이 링크 되었습니다.

위와 같이 하고 나니 정상적으로 git 클라이언트인 sourcetree 를 가지고 svn 서버에 연결하여 pull/push 모두 가능하게 되었습니다. 감사합니다.


신고

posted by youp_han matrim

오늘 아침 우분투 9.04 가 업그레이드 하라고 해서 업그레이드 하고 나니..
리부팅 하라고 해서 했는데, 그 이후.. Netbeans 작동이 되질 않았다.
아웅.. 무슨 이유인지, 주로 뜨는 Netbeans 네모창이 뜨지 않고, 없어져 버리는거다.
황당.. ㅡ,.ㅜa

오류 내용을 보기 위해 콘솔에서 netbeans 를 실행 해 보니

Cannot find java. Please use the --jdkhome switch.

라고 나왔다. 이게 뭘까? 그래서 인터넷을 뒤져보니 나와 같은 오류를 가지고 있는 사람을 찾았다.
(http://www.tibobeijen.nl/blog/2009/05/01/fixing-netbeans-after-ubuntu-9-upgrade/ )

1. netbeans.conf 파일을 찾는다
2.netbeans_jdkhome="/usr/lib/jvm/java-6-sun-1.6.0.13/jre" 라고 씌여 있는 곳을 찾는다.

여기서 버전을 내 컴퓨터 같은 경우 1.6.0.14 로 바꿔주니 잘 작동 되었다.

야호~
신고

posted by youp_han matrim



티스토리 툴바